Pat 甲级 训练真题集 1013!

1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

代码如下

BFS—最后一个测试点超时。。常理两者时间复杂度应该均为O(n^2)尴尬。。。

DFS—AC

#include<iostream>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;

#define MAX 1000

int map[MAX][MAX];
int visited[MAX]={0};
int repaired_road_num;
int N;

void judge_if_connected(int start,int city){
	queue<int> que;
	que.push(start);
	int current_city;
	vector<int> collection;
	while(1){
		if(!que.empty()){
			current_city=que.front();
			que.pop();
			collection.push_back(current_city);
			visited[current_city]=1;
		}else{
			break;
		}
		for(int i=1;i<=N;++i){
			if(!visited[i]&&i!=city){				
					if(map[current_city][i]==1){
						que.push(i);
					}
			}
		}
	}
}
void dfs(int start,int city){
	visited[start]=1;
	for(int i=1;i<=N;++i){
		if(map[start][i]&&i!=city&&!visited[i]){
			dfs(i,city);
		}
	}
}

int main(){
	int M,K;
	cin>>N>>M>>K;
	int c1,c2;
	for(int i=0;i<M;++i){
		cin>>c1>>c2;
		map[c1][c2]=1;
		map[c2][c1]=1;
	}
	int concern_city;
	for(int i=0;i<K;++i){
		cin>>concern_city;
		repaired_road_num=0;
		memset(visited,0,sizeof(int)*MAX);
		for(int j=1;j<=N;++j){
			if(!visited[j]&&j!=concern_city){
				repaired_road_num++;
				//judge_if_connected(j,concern_city	);
				dfs(j,concern_city);
			}
		}
		cout<<repaired_road_num-1<<endl;
	}
	
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦