1027. Colors in Mars (20)
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input
Each input file contains one test case which occupies a line containing the three decimal color values.
Output
For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.
Sample Input
15 43 71
Sample Output
#123456
#include<iostream>
#include<string>
#include<algorithm>
#include<sstream>
#include<vector>
using namespace std;
void decimal_to_13radix(int num){
string s="";
int value;
value=num%13;
switch(value){
case 10:
s+="A";
break;
case 11:
s+="B";
break;
case 12:
s+="C";
break;
default:
stringstream ss;
string temp;
ss<<value;
ss>>temp;
s+=temp;
break;
}
while(num/13!=0){
num/=13;
value=num%13;
switch(value){
case 10:
s+="A";
break;
case 11:
s+="B";
break;
case 12:
s+="C";
break;
default:
stringstream ss;
string temp;
ss<<value;
ss>>temp;
s+=temp;
break;
}
}
if(s.size()==1){
cout<<"0"<<s;
return;
}
reverse(s.begin(),s.end());
cout<<s;
}
int main(){
int red,green,blue;
cin>>red>>green>>blue;
cout<<"#";
decimal_to_13radix(red);
decimal_to_13radix(green);
decimal_to_13radix(blue);
return 0;
}