Pat 甲级 训练真题集 1035!

1035. Password (20)

​ 时间限制

​ 400 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

代码如下:

#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
using namespace std;


int main(){
	int n;
	scanf("%d",&n);
	string name,password;
	vector<string> vec;
	string all;
	for(int i=0;i<n;++i){
		cin>>name>>password;
		int flag=0;
		for(int i=0;i<password.size();++i){
			switch(password[i]){
			case '1':password[i]='@';flag=1;break;
			case '0':password[i]='%';flag=1;break;
			case 'l':password[i]='L';flag=1;break;
			case 'O':password[i]='o';flag=1;break;
			}
		}
		if(flag==1){
			all=name+" "+password;
			vec.push_back(all);
		}
	}
	if(vec.size()==0&&n==1){
		printf("There is 1 account and no account is modified");
		return 0;
	}
	if(vec.size()==0&&n!=1){
		printf("There are %d accounts and no account is modified",n);
		return 0;
	}
	printf("%d\n",vec.size());
	for(int i=0;i<vec.size();++i){
		cout<<vec[i]<<endl;
	}

	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦