Pat 甲级 训练真题集 1039!

1039. Course List for Student (25)

​ 时间限制

​ 200 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

代码如下:

我原先写的(注释的代码)有内存超限扣了2分

看了网上的一个写的特别简洁,对vector拥有者灵活运用的能力,特别帅气


/*
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;


#define N 40001
#define K 2501
class Student{
public:
	string name;
	int courses[K];
	bool operator < (const Student &s)const{
		return name < s.name;
	}
};





int main(){
	int n,k;
	scanf("%d%d",&n,&k);
	vector<Student> vec;
	int course_id;
	int student_num;
	string name;
	for(int i=1;i<=k;++i){
		scanf("%d%d",&course_id,&student_num);
		for(int j=0;j<student_num;++j){
						cin>>name;		
						int flag=0;
						for(int q=0;q<vec.size();++q){
							if(name==vec[q].name){
								flag=1;
								vec[q].courses[course_id]=1;
								break;
							}
						}
						if(flag==0){
							Student  s;
							memset(s.courses,0,sizeof(s.courses));
							s.name=name;
							s.courses[course_id]=1;
							vec.push_back(s);
						}							
		}
	}

	string query_name;
	for(int i=0;i<n;++i){
		cin>>query_name;
		int biaoji=0;
		for(int j=0;j<vec.size();++j){
			if(query_name==vec[j].name){
				biaoji=1;
				int sum=0;
				cout<<query_name;
				for(int q=1;q<=k;++q){
					if(vec[j].courses[q]==1){
						++sum;
					}
				}
				printf(" %d",sum);
				for(int q=1;q<=k;++q){
					if(vec[j].courses[q]==1){
						printf(" %d",q);
					}
				}
				printf("\n");
			}
		}
		if(biaoji==0){
			cout<<query_name;
			printf(" 0\n");
		}
	}


	return 0;
}*/






#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
#define max 26*26*26*10+10
int change(char name[4]){
	int id=0;
	for(int i=0;i<3;++i){
		if(name[i]>='A'&&name[i]<='Z'){
			id=id*26+(name[i]-'A');
		}
	}
	id=id*10+name[3]-'0';
	return id;
}
vector<int> vec[max];
int main(){
	int n,k,course_id,student_num;
	char name[4];
	int id;
	scanf("%d%d",&n,&k);
	for(int i=1;i<=k;++i){
		scanf("%d%d",&course_id,&student_num);
		for(int j=0;j<student_num;++j){
			scanf("%s",name);
			id=change(name);
		//	printf("ss %d\n",id);
			vec[id].push_back(course_id);
			
		}
	}
	char name1[4];
	for(int i=0;i<n;++i){
		scanf("%s",name1);
		id=change(name1);
		printf("%s",name1);
			printf(" %d",vec[id].size());
			sort(vec[id].begin(),vec[id].end());
			for(int j=0;j<vec[id].size();++j){
				printf(" %d",vec[id][j]);
			}
			printf("\n");
	}
	return 0;
}

后面代码参照了1039. Course List for Student (25)-PAT甲级真题

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦