Pat 甲级 训练真题集 1120!

1120. Friend Numbers (20)

​ 时间限制

​ 400 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

代码如下:

#include<cstdio>
#include<set>
#include<vector>
#include<algorithm>

using namespace std;


int return_sum(int x){
	int sum=x%10;
	x=x/10;
	while(x){
		sum+=x%10;
		x/=10;
	}
	return sum;
}

int main(){
	int n;
	scanf("%d",&n);
	int value;
	int sum=0;
	set<int> s;
	for(int i=0;i<n;++i){
		scanf("%d",&value);
		sum=return_sum(value);
		s.insert(sum);
	}
	vector<int> vec;
	for(auto begin=s.begin();begin!=s.end();++begin){
		vec.push_back(*begin);
	}
	sort(vec.begin(),vec.end());
	int size=vec.size();
	printf("%d\n",size);
	for(int i=0;i<size-1;++i){
		printf("%d ",vec[i]);
	}
	printf("%d",vec[size-1]);
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦