Pat 甲级 训练真题集 1044!

1044. Shopping in Mars (25)

​ 时间限制

​ 100 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

\1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15). \2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15). \3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 … DN (Di<=103 for all i=1, …, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print “i-j” in a line for each pair of i <= j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output “i-j” for pairs of i <= j such that Di + … + Dj > M with (Di + … + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

常规方法如下:简单模拟,会有两个测试点超时

AC代码思路:参考网址,利用sum的递增特性进行二分查找找到最右端,然后与m判断若大于等于则存入fianl数组中

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct S{
	int sum;
	int i,j;
};
int cmp1(S s1,S s2){
	if(s1.sum<s2.sum){
		return 1;
	}	
	if(s1.sum==s2.sum&&s1.i<s2.i){
		return 1;
	}
	return 0;
}
int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	vector<int>v(n+1);
	for(int i=1;i<=n;++i){
		scanf("%d",&v[i]);
	}
	int sum=0,flag=0;
	vector<S>all_sum;
	for(int i=1;i<=n;++i){
		for(int j=i;j<=n;++j){
			sum+=v[j];
			
			if(sum==m){
				flag=1;
				printf("%d-%d\n",i,j);
				break;
			}else if(sum>m){
				S s;
				s.sum=sum;s.i=i;s.j=j;
				all_sum.push_back(s);
				break;
			}
		}
		sum=0;
	}
	if(flag==0){
		sort(all_sum.begin(),all_sum.end(),cmp1);
		for(int i=0;i<all_sum.size();++i){
			if(all_sum[0].sum==all_sum[i].sum){
				printf("%d-%d\n",all_sum[i].i,all_sum[i].j);
			}else{
				break;
			}
		}
	}
	return 0;
}

AC代码如下:


#include<iostream>
#include<vector>
using namespace std;
int n,m;
vector<int>sum,final;

void Func(int i,int &j,int &tempsum){
	int left=i,right=n;
	while(left<right){
		int mid=(left+right)/2;
		if(sum[mid]-sum[i-1]>=m){
			right=mid;
		}else{
			left=mid+1;
		}
	}
	j=right;
	tempsum=sum[j]-sum[i-1];
}


int main(){
	scanf("%d%d",&n,&m);
	sum.resize(n+1);
	
	for(int i=1;i<=n;++i){
		scanf("%d",&sum[i]);
		sum[i]+=sum[i-1];
	}
	int minsum=sum[n];
	for(int i=1;i<=n;++i){
		int j,tempsum;
		Func(i,j,tempsum);
		if(tempsum>minsum){
			continue;
		}
		if(tempsum>=m){
			if(tempsum<minsum){
				final.clear();
				minsum=tempsum;
			}
			final.push_back(i);
			final.push_back(j);
		}
	}
	for(int i=0;i<final.size();i+=2){
		printf("%d-%d\n",final[i],final[i+1]);
	}
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦