Pat 甲级 训练真题集 1047!

1047. Student List for Course (25)

​ 时间限制

​ 400 ms

​ 内存限制

​ 64000 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

最开始我直接就利用vector<string> v存储姓名,但是这样不管输入还是输出都要用cin与cout;但是这样会超时;

然后我没找到一个较好的方法,因为错误点就在这,你用printf输出就会对,所以你的名字必须要用char数组保存,你用char保存,你就不能用vector保存char数组,所以在这里我在网上看到了一个用数字连接,就是name[i]存第i个人的名字,而vector存储i,这样就能成功;而这里的一种排序我觉得也挺精妙,就是cmp1函数;

代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;

vector<int> v[2510];
char name[40010][6];
int cmp1(int a,int b){
	return strcmp(name[a],name[b])<0;
}
int main(){
	int n,k;
	scanf("%d%d",&n,&k);
	char s[4];
	int num;
	for(int i=0;i<n;++i){	
		scanf("%s %d",name[i],&num);
		int courseid;
		for(int j=0;j<num;++j){
			scanf("%d",&courseid);
			v[courseid].push_back(i);
		}
	}
	for(int i=1;i<=k;++i){
		sort(v[i].begin(),v[i].end(),cmp1);
		printf("%d %d\n",i,v[i].size());
		for(int j=0;j<v[i].size();++j){
			printf("%s\n",name[v[i][j]]);
		}
	}	
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦