Pat 甲级 训练真题集 1052!

1052. Linked List Sorting (25)

​ 时间限制

​ 400 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

代码如下利用vector与sort

最开始未注意到可能会有无用点

注意点:①头节点可能为-1 ②输入的所以不一定全在输出中

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
class Node{
public:
	int key;
	int current;
	int next;
	bool operator < (const Node &n) const{
		return key<n.key;
	}
};
int main(){
	int n,firstnode;
	scanf("%d%d",&n,&firstnode);

	vector<Node> v(100000);
	for(int i=0;i<n;++i){
		int c,key,next;
		scanf("%d%d%d",&c,&key,&next);
		if(firstnode==-1||c==-1){
			printf("0 -1\n"); 
			return 0;
		}
		v[c].current=c;
		v[c].key=key;
		v[c].next=next;
	}
	vector<Node> v_final;
	int current=firstnode;
	while(current!=-1){
		v_final.push_back(v[current]);
		current=v[current].next;
	}
	sort(v_final.begin(),v_final.end());
	for(int i=0;i<v_final.size();++i){
		if(i!=v_final.size()-1){
			v_final[i].next=v_final[i+1].current;
		}else{
			v_final[i].next=-1;
		}
	}

	printf("%d %05d\n",v_final.size(),v_final[0].current);
	for(int i=0;i<v_final.size();++i){
		if(i!=v_final.size()-1)printf("%05d %d %05d\n",v_final[i].current,v_final[i].key,v_final[i].next);
		else printf("%05d %d -1\n",v_final[i].current,v_final[i].key);
	}
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦