Pat 甲级 训练真题集 1056!

1056. Mice and Rice (25)

​ 时间限制

​ 100 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,…NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,…NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

原代码网址

代码如下:

#include<iostream>
#include<vector>
#include<queue>
#include<algorithm>

using namespace std;

struct Mice{
	int weight;
	int rank;
	int index;
	int index0;
};
int cmp1(Mice m1,Mice m2){
	return m1.index0<m2.index0;
}
int main(){
	int p,g,num;
	scanf("%d%d",&p,&g);
	vector<Mice>v(p);
	vector<int>w(p);
	for(int i=0;i<p;++i){
		scanf("%d",&w[i]);
		
	}
	for(int i=0;i<p;++i){
		scanf("%d",&num);
		v[i].weight=w[num];
		v[i].index=i;
		v[i].index0=num;
	}
	queue<Mice> q;
	for(int i=0;i<p;++i){
		q.push(v[i]);
	}
	while(!q.empty()){
		int size=q.size();
		if(size==1){
			Mice temp=q.front();
			v[temp.index].rank=1;
			break;
		}
		int  group=size/g;
		if(size%g!=0){
			group++;
		}
		Mice maxno;
		int maxweight=-1,cnt=0;
		for(int i=0;i<size;++i){
			Mice temp=q.front();
			v[temp.index].rank=group+1;
			q.pop();
			++cnt;
			if(temp.weight>maxweight){
				maxweight=temp.weight;
				maxno=temp;
			}
			if(cnt==g||i==size-1){
				cnt=0;
				maxweight=-1;
				q.push(maxno);
			}
		}
	}
	sort(v.begin(),v.end(),cmp1);
	for(int i = 0; i < p; i++) {
        if(i != 0)
            printf(" ");
        printf("%d", v[i].rank);
    }
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦