Pat 甲级 训练真题集 1070!

1070. Mooncake (25)

​ 时间限制

​ 100 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

利用单价排序,依次往后买

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

struct Mooncake{
	float amount;
	float price;
};
int cmp1(struct Mooncake &a,struct Mooncake &b){
	return (a.price/a.amount) > (b.price/b.amount);
}
int main(){
	int n;
	float demand;
	scanf("%d%f",&n,&demand);
	vector<Mooncake> v(n);
	for(int i=0;i<n;++i){
		scanf("%f",&v[i].amount);
	}
	for(int i=0;i<n;++i){
		scanf("%f",&v[i].price);
	}
	sort(v.begin(),v.end(),cmp1);

	float maxsum=0;
	if(demand<=v[0].amount){		
		maxsum+=float(v[0].price/v[0].amount)*demand;
		printf("%0.2f",maxsum);
		return 0;
	}
	int index=0;
	while(index<n&&demand>v[index].amount){
		maxsum+=v[index].price;	
		demand-=v[index].amount;
		++index;
	}
	if(index<n){
		maxsum+=float(v[index].price/v[index].amount)*demand;
	}
	printf("%0.2f",maxsum);
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦