pat 甲级 1126

1126. Eulerian Path (25)

​ 时间限制

​ 300 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either “Eulerian”, “Semi-Eulerian”, or “Non-Eulerian”. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

对于这道题我只想说英语不好是硬伤。。。。。。。。。

解题思路利用vector装线路

利用cnt判断有多少个奇数,flag判断是否全为偶数

利用dfs判断是否连通

代码如下:

#include<iostream>
#include<vector>
using namespace std;

vector<int>v[510];
vector<int>visited;
int n,m;
int c=0;
void dfs(int root){
	++c;
	visited[root]=1;
	if(v[root].size()==0){
		return;
	}
	for(int i=0;i<v[root].size();++i){
		if(visited[v[root][i]]==0){
			dfs(v[root][i]);
		}
	}
}
int main(){
	
	scanf("%d%d",&n,&m);
	visited.resize(n+1);
	int a,b;
	for(int i=1;i<=m;++i){
		scanf("%d%d",&a,&b);
		v[a].push_back(b);
		v[b].push_back(a);
	}
	for(int i=1;i<=n;++i){
		if(i!=1)printf(" ");
		printf("%d",v[i].size());
	}
	printf("\n");
	int flag=0;
	int cnt=0;
	
	
	for(int i=1;i<=n;++i){
		if(v[i].size()%2!=0){
			++cnt;	
			flag=1;
		}
	}
	
	dfs(1);
	if(flag==0&&c==n){
		printf("Eulerian\n");
	}else if(c==n&&cnt==2){
		printf("Semi-Eulerian\n");				
	}else{
		printf("Non-Eulerian\n");
	}

	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦