pat 甲级 1124

1124. Raffle for Weibo Followers (20)

​ 时间限制

​ 400 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print “Keep going…” instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

利用set防止出现一样的,利用vector保存winner

代码如下:

#include<iostream>
#include<string>
#include<set>
#include<vector>
using namespace std;



int main(){
	int m,n,s;
	scanf("%d%d%d",&m,&n,&s);
	string temp;
	vector<string>v;
	set<string>se;
	int index=s;
	for(int i=1;i<=m;++i){
		cin>>temp;
		if(i==index){
			if(se.find(temp)!=se.end()){
				index++;
			}else{
				v.push_back(temp);
				se.insert(temp);
				index+=n;
			}
			
		}
	}
	if(v.size()!=0){
		for(int i=0;i<v.size();++i){
			cout<<v[i]<<endl;
		}
	}else{
		printf("Keep going...");
	}
	return 0;
}

打赏一个呗

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦